csf v12.12 enable but stopped after debian upgrade

4 posts Page 1 of 1
Junior Member
Posts: 2
Joined: 04 Jul 2019, 15:29

After upgrade debian stretch to buster csf is enable but stopped.
I tried a fresh install of csf but same problem.
What's going on ?
Please help.
Junior Member
Posts: 2
Joined: 04 Jul 2019, 15:29

I found the solution.
Debian buster use nftables instead of iptables.
To use iptables-legacy try :
# update-alternatives --set iptables /usr/sbin/iptables-legacy
# update-alternatives --set ip6tables /usr/sbin/ip6tables-legacy
# update-alternatives --set arptables /usr/sbin/arptables-legacy
# update-alternatives --set ebtables /usr/sbin/ebtables-legacy

Work for me
Junior Member
Posts: 1
Joined: 25 Jul 2019, 11:54

Hi, we also came across this issue and the fix has worked.

Since Debian 10 was recently released I'm guessing this issue will probably crop up a few more times as people upgrade.

I'd recommend that the authors setup some detection or notification when using Debian 10 (which you could probably detect by checking the /etc/debian_version file) and instruct users to check out the Debian nftables/iptables information and how to switch to iptables on the following page from the Debian wiki:


Just a suggestion or course. Thanks to the developers for maintaining this firewall script.

Posts: 1450
Joined: 01 Oct 2008, 09:24

This will be implemented in the next csf release.
4 posts Page 1 of 1