iPv6 error

This forum is only for reproducible bugs with csf and lfd (i.e. not iptables problems, lack of understanding how to use a feature, etc). Posts must be accompanied with full technical details of the problem and how it can be recreated. Any posts not adhering to this, or not considered bugs, will be moved to the General Discussion (csf) forum.
Post Reply
ae6dx
Junior Member
Posts: 8
Joined: 10 Jun 2010, 01:08

iPv6 error

Post by ae6dx »

I'm getting the following warning:
IPv6 appears to be enabled [ifconfig: fe80::225:64ff:fe3d:4bec/64 Scope:Link, ::1/128 Scope:Host]. If ip6tables is installed, you should enable the csf IPv6 firewall (IPV6 in csf.conf). To disable IPv6 on RHEL/CentOS you should follow this link

Yet if I set IPv6_SPI to 1 I get a cron Warning email:
*WARNING* Kernel 2.6.18-164.15.1.el5PAE may not support an ip6tables SPI firewall. You should set IPV6_SPI to "1" in /etc/csf/csf.conf

What is going wrong here?

chirpy
Moderator
Posts: 3537
Joined: 09 Dec 2006, 18:13

Post by chirpy »

It's a bug in that warning which should be the other way round - IPV6_SPI should be set to 0 if a older kernel is being used. We'll have a fix for it in the next release.

ae6dx
Junior Member
Posts: 8
Joined: 10 Jun 2010, 01:08

Post by ae6dx »

I just upgraded to the latest version. I have IPV6_SPI set to 1 and IPV6 set to 1. I am still getting the warning.

ae6dx
Junior Member
Posts: 8
Joined: 10 Jun 2010, 01:08

Post by ae6dx »

Can anyone help here?

chirpy
Moderator
Posts: 3537
Joined: 09 Dec 2006, 18:13

Post by chirpy »

You should be setting IPV6_SPI to 0 not 1 with the kernel you are running.

ae6dx
Junior Member
Posts: 8
Joined: 10 Jun 2010, 01:08

Post by ae6dx »

Ok if I set to 0 as you say in the firewall scan I still get:

IPv6 appears to be enabled [ifconfig: fe80::225:64ff:fe3d:4bec/64 Scope:Link, ::1/128 Scope:Host]. If ip6tables is installed, you should enable the csf IPv6 firewall (IPV6 in csf.conf). To disable IPv6 on RHEL/CentOS you should follow this link

Does this mean the bug is not fixed?

Infopro
Junior Member
Posts: 142
Joined: 15 Dec 2006, 00:22

Post by Infopro »

To disable IPv6 on RHEL/CentOS you should follow this link
Did you disable it properly?

ae6dx
Junior Member
Posts: 8
Joined: 10 Jun 2010, 01:08

Re: iPv6 error

Post by ae6dx »

The link to disable it points to http://kbase.redhat.com/faq/docs/DOC-8711

This takes me to a page where I need to buy a Red Hat subscription to view it. Can I get this without paying?

Post Reply