CSF Blocking SMTP to Sendgrid

6 posts Page 1 of 1
mrdigital
Junior Member
Posts: 1
Joined: 29 Jul 2015, 04:31


Hello,

I'm hoping someone can help me, I currently have a dedicated server running CLOUDLINUX 6.6 x86_64 standard – server WHM 11.50.0 (build 29) and I use CSF Firewall.

I've decided to use "SendGrid" (www.sendgrid.net) as an SMTP service to send invoices through my WHMCS system. Everything works for a couple of days and then the SMTP no longer works. Each time this happens, I have to disable CSF and re-enable, and then SMTP with sendgrid works again.

Does anyone have any suggestions how I can stop CSF from blocking SMTP to sendgrid servers?

Any assistance would be much appreciated.

Kind Regards,
Sean
CmdrSharp
Junior Member
Posts: 1
Joined: 10 May 2016, 22:57


I realize that this is a year old thread - but it's also the only one I could find on the issue, and I'm experiencing the exact same issue. Works fine for a day or two, then eventually WHMCS stops sending out e-mails and says that they're not able to. Restarting CSF works every time.

I've tried whitelisting SendGrid IP's, but that does not appear to help.

Any clue what could be causing this? SMTP_BLOCK is currently disabled.
Rabijit
Junior Member
Posts: 1
Joined: 06 Aug 2016, 01:35


@CmdrSharp Did you find any solution ?
FDGWeb
Junior Member
Posts: 3
Joined: 26 Jul 2016, 01:08


This is still occurring for us.

CSF is blocking the TCP request after a short while... dropping the connection to Sendgrid. We're working with our techs on this .. but it is definitely CSF. When we restar the firewall (CSF) it work again for hours to days before being blocked again. It is blocking internally in CSF.
padlavoine
Junior Member
Posts: 2
Joined: 16 Nov 2016, 19:42


Hi all,

I added line in css.allow with ip of smtp.sendgrid.net and restart css

tcp|in|dpt=587|d=159.122.224.196
tcp|out|dpt=587|s=159.122.224.196
tcp|in|dpt=587|d=159.122.224.197
tcp|out|dpt=587|s=159.122.224.197

but it does not change anything.
Any idea ?
Nirjonadda
Junior Member
Posts: 13
Joined: 25 Nov 2013, 19:58


10 Aug 2016, 17:33FDGWeb wrote:
This is still occurring for us.

CSF is blocking the TCP request after a short while... dropping the connection to Sendgrid. We're working with our techs on this .. but it is definitely CSF. When we restar the firewall (CSF) it work again for hours to days before being blocked again. It is blocking internally in CSF.
I am have same issue. @ForumAdmin do you have any fix for this issue?
6 posts Page 1 of 1