UI not loading on default config with SSL certificate error?

Post Reply
droid1
Junior Member
Posts: 1
Joined: 15 Dec 2019, 12:21

UI not loading on default config with SSL certificate error?

Post by droid1 »

Just installed the latest csf on my Debian 10 setup and it works fine, the Web-UI is however showing a connection refused error. Checking the lf logs shows this error:

Code: Select all

Dec 15 12:15:04 xxxx lfd[6078]: UI: *Error* cannot open server on port 1026: Failed to load certificate from file (no PEM, DER or PKCS12) error:0D0680A8:asn1 encoding routines:asn1_check_tlen:wrong tag error:0D07803A:asn1 encoding routines:asn1_item_embed_d2i:nested asn1 error, at line 8859 
Searching on internet it seems the certificate format is not something compatible on my linux installation. lfd and csf bot starts and run fine.

welkeini
Junior Member
Posts: 1
Joined: 25 Dec 2019, 16:14

Re: UI not loading on default config with SSL certificate error?

Post by welkeini »

droid1 wrote:
15 Dec 2019, 12:26
Just installed the latest csf on my Debian 10 setup and it works fine, the Web-UI is however showing a connection refused error. Checking the lf logs shows this error:

Code: Select all

Dec 15 12:15:04 xxxx lfd[6078]: UI: *Error* cannot open server on port 1026: Failed to load certificate from file (no PEM, DER or PKCS12) error:0D0680A8:asn1 encoding routines:asn1_check_tlen:wrong tag error:0D07803A:asn1 encoding routines:asn1_item_embed_d2i:nested asn1 error, at line 8859 
Searching on internet it seems the certificate format is not something compatible on my linux installation. lfd and csf bot starts and run fine.
SAME THING TO ME
Thanks
Liteblue

mojocreator
Junior Member
Posts: 6
Joined: 03 Apr 2017, 00:05

Re: UI not loading on default config with SSL certificate error?

Post by mojocreator »

I am running into the exact same issue, new install, CSF/LFD are running and working fine but I get a certificate error. Is this a known issue or are we missing something? The UI directory has a key/crt but the error is asking for a PEM, DR or PKCS512. Converting the CRT to PEM doesn't work either.

Code: Select all

Jan 14 23:29:54 server lfd[13471]: UI: *Error* cannot open server on port 6857: Failed to load certificate from file (no PEM, DER or PKCS12) error:0D0680A8:asn1 encoding routines:asn1_check_tlen:wrong tag error:0D07803A:asn1 encoding routines:asn1_item_embed_d2i:nested asn1 error, at line 9169

Post Reply