CSF problems on fresh CloudLinux 7.7 with cPanel

1 post Page 1 of 1
clickright
Junior Member
Posts: 1
Joined: 04 Dec 2019, 19:12


Hi, I always install CSF on CloudLinux 7 + cPanel (Centos 7 + cPanel + Cloud Linux) and it works perfectly. But today I was setting up a new server and found that after installing CSF, the lfd service is failing to start.

I've tried restarting CSF and LFD trough SSH and WHM and no success.

When checking LFD status I get this:
Code: Select all
lfd.service - ConfigServer Firewall & Security - lfd
   Loaded: loaded (/usr/lib/systemd/system/lfd.service; enabled; vendor preset: disabled)
   Active: failed (Result: signal) since Wed 2019-12-04 14:15:55 EST; 3min 6s ago
  Process: 8095 ExecStart=/usr/sbin/lfd (code=killed, signal=KILL)

Dec 04 14:15:55 srv systemd[1]: Starting ConfigServer Firewall & Security - lfd...
Dec 04 14:15:55 srv systemd[1]: lfd.service: control process exited, code=killed status=9
Dec 04 14:15:55 srv systemd[1]: Failed to start ConfigServer Firewall & Security - lfd.
Dec 04 14:15:55 srv systemd[1]: Unit lfd.service entered failed state.
Dec 04 14:15:55 srv systemd[1]: lfd.service failed.
Edit:

That error is expected, since the CSF was in TESTING MODE. After setting TESTING = Off, I was not able to run lfd.

So I tried to reboot the server and when it booted up lfd was up and running. When I check the "lfd status" in the CSF interface, I got this:
Code: Select all
● lfd.service - ConfigServer Firewall & Security - lfd
   Loaded: loaded (/usr/lib/systemd/system/lfd.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2019-12-05 06:59:25 EST; 33min ago
  Process: 3161 ExecStart=/usr/sbin/lfd (code=exited, status=0/SUCCESS)
 Main PID: 3189 (lfd - sleeping)
   CGroup: /system.slice/lfd.service
           └─3189 lfd - sleepin

Dec 05 06:59:25 srv systemd[1]: Starting ConfigServer Firewall & Security - lfd...
Dec 05 06:59:25 srv systemd[1]: Started ConfigServer Firewall & Security - lfd.
Dec 05 07:04:26 srv lfd[3189]: SYSLOG check [Ym2thxnv0H7NcSdi]
Dec 05 07:09:26 srv lfd[3189]: SYSLOG check [TVGnuNDu8qYOsZy59CVSLMedcxQ]
Dec 05 07:14:27 srv lfd[3189]: SYSLOG check [37vsYmdJ4KXorq2Qt1D86QA54e]
...
In other servers I have, I get only this message:
Code: Select all
Status of lfd: Running
Is the first message ok? That is the expected "status"? This means everything is running good?

Thank you!
1 post Page 1 of 1