lfd alert emails - no body text

8 posts Page 1 of 1
petre75
Junior Member
Posts: 5
Joined: 03 Dec 2019, 00:14


Ever since the 28th November, the majority of lfd alerts i receive via email no longer have any body text.
This started off with the occasional alert not having body text (about 1 in 10) to now ALL of them not having body text.
It doesn't matter which alert: Excessive resource usage, Suspicious process, root access alert, blocked etc. are all affected.
The email headers are populated correctly.

All other alerts sent from cpanel, cron etc are working fine.

I have searched and haven't found anyone else with similar issues.

Can anyone suggest what the issue may be and where to start looking?
BassTeQ
Junior Member
Posts: 4
Joined: 29 Dec 2013, 22:11


I too am having the same issue, is there a fix for this?
petre75
Junior Member
Posts: 5
Joined: 03 Dec 2019, 00:14


Ok, i am not alone!

Still having issue after update cPanel to 84.0.16.
CSF version 13.08

However, the integrityalert.txt ( System Integrity checking detected a modified system file.. ) email does have Body text....
krisdv
Junior Member
Posts: 8
Joined: 04 Mar 2011, 11:27


I'm experiencing the same behaviour, on some servers there is no body text in email but not on all of my servers although running the same config (same os, same cpanel version same csf version).
petre75
Junior Member
Posts: 5
Joined: 03 Dec 2019, 00:14


04 Dec 2019, 04:26petre75 wrote:
However, the integrityalert.txt ( System Integrity checking detected a modified system file.. ) email does have Body text....
I just received another integrity alert..... now no body text!
petre75
Junior Member
Posts: 5
Joined: 03 Dec 2019, 00:14


I have found a workaround.

The issue seems to be with o365 exchange.
I have my root email forwarded to my o365 exchange account.
lfd was set to send alerts to default which is root.

To prove the issue, i did the following:
*all following settings with LF_ALERT_FROM left at default (root)
Set LF_ALERT_TO gmail account - Body Text works
Set LF_ALERT_TO outlook account - Body Text works
Set LF_ALERT_TO o365 account (root forwarder) - Body Text NOT Work
Set LF_ALERT_TO different o365 account (same tenant) - Body Text NOT work

As i want the emails sent to my main o365 account, i tried:
set LF_ALERT_FROM gmail account
set LF_ALERT_TO o365 account (root forwarder)
and all seems to be working.

Leaving like this for now.

I am not concerned about the messages going to spam as i have mail flow rules setup in exchange so all emails from my server bypass junk.

Hope this helps
BallyBasic79
Junior Member
Posts: 78
Joined: 22 Aug 2019, 21:43


Curious if it is a rendering issue.

Is the message body totally missing, or just not shown?
If you look at the message source, is it there?
If you use a third party email client to look at the message sent to O365, does it show?
petre75
Junior Member
Posts: 5
Joined: 03 Dec 2019, 00:14


05 Dec 2019, 04:01BallyBasic79 wrote:
Curious if it is a rendering issue.

Is the message body totally missing, or just not shown?
If you look at the message source, is it there?
If you use a third party email client to look at the message sent to O365, does it show?
I am not sure, o365 only shows header source.
The body text doesn't display in Outlook desk client, Outlook android client, Outlook web client.
I don't have the time to setup a 3rd party client

However, I compared headers between an old alert with working body text and a newer one without working body text.
The new headers don't have:
MIME-Version: 1.0
Content-Type: text/plain

Sure enough, i add those 2 lines to an lfd alert template (above the newline) to test, and it now works like it used to for that alert.

So another option is to add those 2 lines to ALL the lfd alert templates.... or add them in the Sendmail.pm module if feeling adventurous :)
8 posts Page 1 of 1