Mail Scanner stops processing mail queue

Discuss the ConfigServer MailScanner Front-End script
2 posts Page 1 of 1
mellowms_dev
Junior Member
Posts: 1
Joined: 09 May 2019, 14:13


Hi All,

We are having an issue periodically where by MailScanner will stop processing our mail queue and the server load will spike to the point where it is mostly unusable. In all instances going to the MailScanner FE interface and clicking restart fixes the issue within 30 seconds or so and the server load drops back down - it however does not fix the issue as the mail queue continues to rise

In each instance we have to click the button for "Force Clamavconnector Update" which then fixes the issue and the mail queue starts to go back down, when running this the response is as follows:
Code: Select all
Removing old MailScanner Hooks if present (ignore any errors here)...
There was a failure removing a hook.
No matching hooks found
There was a failure removing a hook.
No matching hooks found
Switching MailScanner to Clamavconnector (removing custom ClamAV)...
Installing Clamavconnector...
Restart services...
Redirecting to /bin/systemctl restart crond.service
Redirecting to /bin/systemctl restart MailScanner.service
Following this it would seem that there is a potential issue where by the hook between MailScanner and ClamAv keeps getting removed but we are unsure why this would happen

Has anyone else seen or experiences anything like this in the past? it started around 2 months ago now and periodically causes issues. Our server configuration is below

CloudLinux 7.6
WHM 78.0.23
MailScanner 5.0.2
MailScanner FE 8.26
ConfigServer MailScanner Script 3.16

Regards,
Jamie
Sarah
Moderator
Posts: 803
Joined: 09 Dec 2006, 22:49


Have you gone through all the suggestions in these knowledgebase articles?

https://support.configserver.com/en/knowledgebase/article/help-mailscanner-isnt-workingmail-isnt-being-delivered-what-do-i-do

https://support.configserver.com/knowledgebase/article/mail-processing-and-delivery-seems-very-slow-and-there-are-a-lot-of-emails-in-the-queue

As a start you need to check the maillog for errors.

The errors in the clamavconnector update are not relevant, you can "ignore any errors here" according to the output.

Regards,
Sarah
2 posts Page 1 of 1