ConfigServer Security&Firewall WHM/Cpanel plugin not loading - blank page

2 posts Page 1 of 1
Margarit Cezar
Junior Member
Posts: 1
Joined: 05 Mar 2019, 10:01


Hello,
We have a VPS with Centos 7.6 and Cpanel/WHM installed. We installed CSF and it worked great until some days ago. The interface in WHM doesn't load and it is showing a blank page.
In the error logs we fond the below:

Below you can find the error log from /usr/local/cpanel/logs/error_log:

[2019-03-05 06:54:28 +0200] warn [whostmgrd] The subprocess (/usr/local/cpanel/whostmgr/docroot/cgi/configserver/csf.cgi) exited with an error: The subprocess ended prematurely because it received the “PIPE” (13) signal. at /usr/local/cpanel/Cpanel/Server/Handlers/SubProcess.pm line 251.
Cpanel::Server::Handlers::SubProcess::_report_subprocess_errors(Cpanel::Server::Handlers::SubProcess=HASH(0x1eb2440)) called at /usr/local/cpanel/Cpanel/Server/Handlers/SubProcess.pm line 109
Cpanel::Server::Handlers::SubProcess::handler(Cpanel::Server::Handlers::SubProcess=HASH(0x1eb2440), __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, 28700, __CPANEL_HIDDEN__, GLOB(0x1eae8f8), __CPANEL_HIDDEN__, ...) called at cpsrvd.pl line 7013
cpanel::cpsrvd::cgiHandler(__CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__, __CPANEL_HIDDEN__) called at cpsrvd.pl line 6444
cpanel::cpsrvd::dodoc_whostmgrd() called at cpsrvd.pl line 1884
cpanel::cpsrvd::dodoc(HASH(0x13bfbf8)) called at cpsrvd.pl line 1572
cpanel::cpsrvd::handle_one_connection(6) called at cpsrvd.pl line 1031
cpanel::cpsrvd::script() called at cpsrvd.pl line 363

This seems to be related to the csf.deny file which has over 600 lines. If I rename the file and use the default one and lets say insert about 200 lines (IP blocks), the CSF plugin in WHM it is accessible. If I go past that number with 10-20 or more IP blocks it stops loading.
I already modified the limit set in csf.config file to 1000 and restarted the firewall but with no positive results.

We need all those IPs blocked from our old csf.deny file to work and the interface in WHM/CPanel to be accessible.

Any input/solution on this would be greatly appreciated.
WebDrafter
Junior Member
Posts: 1
Joined: 21 Mar 2019, 13:16


I am also experiencing this issue. CloudLinux with cPanel / WHM as well. I can't access Mailscanner Frontend at all. Emails are still sending and the log is working as I was able to view it via command line but I'm still getting the following error in tow with the blank screen.

[2019-03-20 08:33:42 -0500] warn [whostmgrd] The subprocess (/usr/local/cpanel/whostmgr/docroot/cgi/configserver/mailscanner.cgi) exited with an error: The subprocess ended prematurely because it received the “PIPE” (13) signal. at /usr/local/cpanel/Cpanel/Server/Handlers/SubProcess.pm line 251

Any help would be appreciated as it's a third party plugin on my server and I cannot get help from WHM. I've tried everything from https://support.configserver.com/en/kno ... at-do-i-do to no avail.
2 posts Page 1 of 1