Help Loading a Custom Blocklist

1 post Page 1 of 1
developcents
Junior Member
Posts: 1
Joined: 15 Sep 2018, 21:19


I have generated a custom blocklist that I'm trying to load into /etc/csf/csf.blocklists.

My entry is at the very bottom of that file, and looks like this:
Code: Select all
DEVELOPCENTS|86400|0|https://my.private.url/abusive_ip_addresses.txt
I have confirm that I can wget this file from the server in question (i.e. https://my.private.url/abusive_ip_addresses.txt is a valid URL).

After I enter that in, and restart csf & lfd, I run a 'csf -l' to list the rules, and I see:
Chain DEVELOPCENTS (1 references)
num pkts bytes target prot opt in out source destination
... and nothing else related to that chain.

Currently, that text document contains 12 lines, all of which are /24 subnets, in the following format:
x.x.x.0/24

Other than that, there is nothing in that text file. It is identical in format to several of the URLs found in the csf.blocklists file. When I uncomment one of the existing lines, such as the one from SPAMHAUS, and restart, those IPs get loaded in without a problem. However, when I tried to add another "custom" list (from AlienVault), I got the same results with AlientVault that I'm getting with my DEVELOPCENTS chain.

What's going on, and what further information can I provide to help you help me?
1 post Page 1 of 1