ETH_DEVICE not working

1 post Page 1 of 1
n8v8r
Junior Member
Posts: 9
Joined: 21 Apr 2018, 21:52


Linux server 4.9.0-6-amd64 #1 SMP Debian 4.9.88-1 (2018-04-29) x86_64 GNU/Linux
CSF 12.03
OpenVPN 2.4.4 x86_64-pc-linux-gnu

public iface eth0
private vpn iface tun1

My understanding of
If you only want iptables rules applied to a specific NIC
would be that with setting
Code: Select all
ETH_DEVICE = "eth0"
that csf would ignore other ifaces. But unfortunately it does not. With this setting in place and running a
Code: Select all
ping
inside the tun1 iface the output is
Operation not permitted
Instead it requires
Code: Select all
ETH_DEVICE_SKIP  = tun1
to exclude the tun iface from csf
1 post Page 1 of 1