Internal Server Error

12 posts Page 1 of 2
ikaruz
Junior Member
Posts: 8
Joined: 07 Mar 2007, 21:13


Hi

We are receiving this error when running CMQ

Internal Server Error

Premature end of script headers: /usr/local/cpanel/whostmgr/docroot/cgi/addon_cmq.cgi: Please check /usr/local/cpanel/logs/error_log for the exact error.
cpsrvd/11.23.1

Our server specs
WHM 11.23.0 cPanel 11.23.3-R25133
CENTOS Enterprise 4.6 i686 on virtuozzo - WHM X v3.1.0

eeror_log says:
Compilation failed in require at /usr/local/cpanel/whostmgr/docroot/cgi/addon_cmq.cgi line 13.
BEGIN failed--compilation aborted at /usr/local/cpanel/whostmgr/docroot/cgi/addon_cmq.cgi line 13.
Internal Error: "GET /cgi/addon_cmq.cgi HTTP/1.1" Premature end of script headers: /usr/local/cpanel/whostmgr/docroot/cgi/addon_cmq.cgi: Please check /usr/local/cpanel/logs/error_log for the exact error.

 

ckh
Junior Member
Posts: 147
Joined: 10 Dec 2006, 15:35


Try reinstalling perl, I had the same error on a couple servers.

 

ikaruz
Junior Member
Posts: 8
Joined: 07 Mar 2007, 21:13


Thankis Cris, but don't imagine why te same error on all servers with all config servers scripts. I really don't want to reinstall perl in all of our boxes
If anyone at configservers could look at this issue ... because is afecting all of their scripts

 

ckh
Junior Member
Posts: 147
Joined: 10 Dec 2006, 15:35


I don't think it has anything to do with the configserver scripts, I think it has to do more with a upcp

One other problem I had was phpmyadmin access within cpanel for an affected server. I was also getting an error message from the cpanel hourly cron.

More than just the configserver scripts were affected so you may just have to bite the bullet and reinstall perl.

 

ikaruz
Junior Member
Posts: 8
Joined: 07 Mar 2007, 21:13


Maybe I was not clear, I'm not blaming configserver for the error.
But at this time the only affected scripts are configservers WHM plugins.

I'm totally sure that the problem is a "collateral damage" of upcp, so I was expecting that Chirpy or other configserver staff may see the error and tell more about it

 

ckh
Junior Member
Posts: 147
Joined: 10 Dec 2006, 15:35


Well, if reinstalling perl fixes it, then it's a cpanel problem and you will need to reinstall it on all your servers anyway.

Try it on one box. If it doesn't work, then you haven't lost much time. If it does work, then you'll need to do it to all your boxes and I don't think there's going to be any other solution.

The configserver scripts is the 'visible' problem on your servers. I have logview installed and it was showing the same error. There were other indications, like the phpmyadmin access via cpanel although whm phpmyadmin worked fine, the hourly cron.

You posted a problem, I had the same incident, I posted my solution. I don't know what more you are looking for.

 

nabuhonodozor
Junior Member
Posts: 48
Joined: 29 Oct 2007, 07:01


Hi,
Ive got info from ServInt NOC "This is because cPanel accidentally downgraded everyone to perl 5.8.5. I have begun reupdating you to 5.8.8" and reupdating fix this issue.

best regards,
Piotr

 

Lucas
Junior Member
Posts: 10
Joined: 01 Apr 2007, 19:02


Yeah, I also noted this one a couple of our customers servers. cPanel should be more careful with that.

 

shacker
Junior Member
Posts: 8
Joined: 13 Jan 2007, 06:00


Reading through these forum posts, I'm seeing three options/suggestions:

- Re-upgrade perl
- Re-run the CSF installation script (which is where, by the way?)
- Change the cPanel update settings

Is there a "recommended" approach to get this fixed? Thanks.

 

shacker
Junior Member
Posts: 8
Joined: 13 Jan 2007, 06:00


Looks like this got fixed automatically in the next night's system update.
12 posts Page 1 of 2