URGENT, in new cmq: v1.30 after "delete", "deliver" deletes email

5 posts Page 1 of 1
Sergio
Junior Member
Posts: 1281
Joined: 12 Dec 2006, 14:56
by Sergio » 28 Sep 2016, 17:21
Hi, Could you please check the following:

1. Enter into CMQ
2. Click "delete" button of an email
3. Then, click "deliver" button on the email that has replaced the one that was deleted and the email is deleted as well instead of delivering it.

Sergio
ForumAdmin
Moderator
Posts: 1228
Joined: 01 Oct 2008, 09:24
by ForumAdmin » 28 Sep 2016, 21:00
I am unable to recreate this. What browser and version are you using?
ForumAdmin
Moderator
Posts: 1228
Joined: 01 Oct 2008, 09:24
by ForumAdmin » 28 Sep 2016, 21:11
Actually, I think I might know what is happening. The bootstrap modal uses an iframe that displays the results of clicking a button. When you click another one (e.g. to deliver) it will display the previous iframe results until the new one has anything to overwrite it. This can take a long time (delivery) and it appears as though the email was deleted, when in reality you are simply seeing the old screen before the new one updates the modal. We'll look at blanking out the modal between displays to avoid the confusion, but we do not believe that emails are being deleted erroniously from our testing.
ForumAdmin
Moderator
Posts: 1228
Joined: 01 Oct 2008, 09:24
by ForumAdmin » 28 Sep 2016, 21:27
We've released v1.32 of cmq which should avoid this confusion with the details being displayed in the modal.
Sergio
Junior Member
Posts: 1281
Joined: 12 Dec 2006, 14:56
by Sergio » 28 Sep 2016, 21:35
Thanks!
5 posts Page 1 of 1