URLGET LWP not working on fresh CentOS 6.6

7 posts Page 1 of 1
tandyuk
Junior Member
Posts: 9
Joined: 06 Jan 2008, 14:03


Ok, so most of my machines are cpanel.
This one is just a plain centos box.

So i installed csf as usual, and restarted it...

*WARNING* URLGET set to use LWP but perl module is not installed, reverting to HTTP::Tiny

Ok, no problem, lets install it...

Package 4:perl-5.10.1-136.el6_6.1.x86_64 already installed and latest version
Package perl-IO-Socket-SSL-1.31-2.el6.noarch already installed and latest version
Package perl-Net-SSLeay-1.35-9.el6.x86_64 already installed and latest version
Package perl-Net-LibIDN-0.12-3.el6.x86_64 already installed and latest version
Package perl-IO-Socket-INET6-2.56-4.el6.noarch already installed and latest version
Package perl-Socket6-0.23-4.el6.x86_64 already installed and latest version

So any ideas why csf cant see it, or is this a bug?

It works fine on 7 other Centos/Cloudlinux 6.x machines.


And then solved my own problem...
yum install perl-libwww-perl
And a load of dependencies.


Perhaps this requirement could be added to the install/readme.txt

Thanks :)
jcats
Junior Member
Posts: 29
Joined: 03 Jan 2015, 14:36


Never had this issue before, even when using a minimal Centos install. Weird =X
agriz
Junior Member
Posts: 3
Joined: 24 Aug 2013, 15:37


Thanks. The error is gone. But nothing loaded after installing the perl module.

Just logo and " ConfigServer Security & Firewall - csf v7.68"
Nothing else.
What to do now?
RudyS
Junior Member
Posts: 1
Joined: 10 Aug 2015, 14:15


Had exactly the same problem.
Thank you very much for your solution.
Firewalls4Life
Junior Member
Posts: 57
Joined: 21 Nov 2011, 18:43


For Ubuntu the install command and package name is:
Code: Select all
apt-get install libwww-perl
Travis Banger
Junior Member
Posts: 4
Joined: 19 Nov 2016, 18:35


tandyuk wrote:
And then solved my own problem...
yum install perl-libwww-perl
And a load of dependencies.

Perhaps this requirement could be added to the install/readme.txt
I also had the exact same problem, but in a computer running Ubuntu. The "perl-libwww-perl" package was not found, so in a wild guess, I tried this:
Code: Select all
# apt-get install  libwww-perl
and it worked fine. !
Aza_Oberman
Junior Member
Posts: 2
Joined: 19 Feb 2015, 00:45


The beat of this thread goes on with the next release of CentOS 7.3.1611 (Core)..

CPAN reports that LWP is installed and current.

The CentOS 6 panacea cited at the start of this thread was executed:
yum install perl-libwww-perl
returns:
Package perl-libwww-perl-6.05-2.el7.noarch already installed and latest version
.

Nevertheless, CSF "Quick Allow" returns:
*WARNING* URLGET set to use LWP but perl module is not installed, reverting to HTTP::Tiny
Allowing 96.230.221.36...
*WARNING* URLGET set to use LWP but perl module is not installed, reverting to HTTP::Tiny
Adding 96.230.221.36 to csf.allow and iptables ACCEPT...
csf: IPSET adding [96.230.221.36] to set [chain_ALLOW]
...Done.
Any thoughts?

Aza D. Oberman 9/11/2017
7 posts Page 1 of 1