Christmas Holiday

We will be closing our Store, Sales and Helpdesk from 17:30 Wednesday, 23rd December 2020 to 09:00 Monday, 4th January 2021. No orders, support requests or sales emails will be processed between those dates.

If you purchase a license or Service Package before the closing date and require installation, please be sure to leave at least 24 hours before then for the work to be done. Otherwise, any work will be scheduled for after this period.

csf gets error and cannot upgrade

Post Reply
modom
Junior Member
Posts: 12
Joined: 26 Apr 2009, 19:24

csf gets error and cannot upgrade

Post by modom »

Hi,

When csf tried to upgrade earlier this morning I get an email that says:
Oops: Unable to download: 599 - Could not connect to 'www.configserver.com:80': IO::Socket::INET: connect: Connection timed out
In WHM now there is only this text and no button to click to upgrade.
Upgrade
Unable to connect to http://www.configserver.com, retry in 300 seconds. An Upgrade button will appear here if new version is detected
The version installed is csf v6.36.

How do I fix it so I can upgrade?

Thanks!
Nwind Support
Junior Member
Posts: 2
Joined: 21 Jan 2015, 03:47

Re: csf gets error and cannot upgrade

Post by Nwind Support »

I have the same error on csf v7.13 and cxs v5.03
I have installed perl-Crypt-SSLeay that resolved another poster's problem with the upgrade.
Have you had any success in resolving this error?
Would following the install instructions resolve the issue without uninstalling cxs or csf?

Thank you,
Kensel
modom
Junior Member
Posts: 12
Joined: 26 Apr 2009, 19:24

Re: csf gets error and cannot upgrade

Post by modom »

I have this same exact error.

I have the US,GB,UK as the country CC_ALLOW_FILTER because I am getting so much spam and this is the only way I can stop it but then I cannot upgrade either.

Am using sf 7.58 version.
jamesshallcross
Junior Member
Posts: 1
Joined: 04 Feb 2015, 10:40

Re: csf gets error and cannot upgrade

Post by jamesshallcross »

I am also not able to upgrade.

CentOS 7
CSF v7.60 (which i just manually upgraded from v7.58)
Webmin


Upgrade
Unable to connect to <download link removed so this post works>, retry in 300 seconds. An Upgrade button will appear here if new version is detected.

I tried with csf stopped (to see if the firewall was blocking access, same error.

I can use wget/curl fine from console, dns lookups work, so i think this might be a problem with csf itself ?

James
SeaTea
Junior Member
Posts: 2
Joined: 04 Feb 2015, 14:53

Re: csf gets error and cannot upgrade

Post by SeaTea »

I have the same on a new installation CentOS 7 on a vps with csf v7.60 and webmin.

I am using the same setup on another VPS, but with CentOS 6 and do not see the upgrade error. Tried to install the Perl-Crypt but that does not change anything.

Is there a logfile where I can see an error message ? (nothing in /var/log/messages)
SeaTea
Junior Member
Posts: 2
Joined: 04 Feb 2015, 14:53

Re: csf gets error and cannot upgrade

Post by SeaTea »

I found the solution for me after testing manual update with:

Code: Select all

/usr/sbin/csf -u


I got the following error:

Code: Select all

Oops: Unable to download: Protocol scheme 'https' is not supported (LWP::Protocol::https not installed)
So the solution for me was easy:

Code: Select all

yum install perl-LWP-Protocol-https
ForumAdmin
Moderator
Posts: 1489
Joined: 01 Oct 2008, 09:24

Re: csf gets error and cannot upgrade

Post by ForumAdmin »

That information is provided in /etc/csf/csf.conf under the URLGET option.
Post Reply