CSF block Domain WHOIS Lookup in WHMCS(solved)

8 posts Page 1 of 1
zhihao
Junior Member
Posts: 9
Joined: 01 Mar 2013, 01:28


I use centos 5.10 32bit + cPanel 11.40.1 + WHMCS 5.3.3 on my VPS server. And my CSF is the newest v6.43. When I use "Domain WHOIS Lookup" in WHMCS admin panel, I get the warning message below: There was a problem connecting to the domain registry. Please check port 43 is open in your servers firewall. Error: 110 - Connection timed out

I try to use "whois ip" in ssh shell and get the message below:
root@hk [~]# whois ip
[Querying whois.nameserver]
[Unable to connect to remote host]

But I have already add tcp-out port 80 in CSF. It is really strange. So I have to turn CSF+LFD off and everything is OK. I don't know which setting block "whois" lookup. Could you please give me some advice? Thank you.
Last edited by zhihao on 11 Feb 2014, 10:08, edited 1 time in total.
Karel
Junior Member
Posts: 28
Joined: 11 Jul 2013, 20:22


Was it working before?
Anyway try this. Add port 43 to TCP_OUT in section IPv4 Port Settings
Example:
Allow outgoing TCP ports
Code: Select all
TCP_OUT = 20,21,22,25,53,80,110,113,443,43
omaster
Junior Member
Posts: 2
Joined: 09 Feb 2014, 05:41


I have the same issue from yesterday. I have whmcs 5.2.16 centos 6.5 (64 bit) cpanel 11.40.1 build 11.
TCP_OUT have port 43 enabled, so i cant find the solution to this issue.


I tried in console# telnet whois[dot]godaddy[dot]com 43

Trying 68.178.211.43...
Connected to whois[dot]godaddy[dot]com.
Escape character is '^]'.
Connection closed by foreign host.

Any advice to solve this issue is very appreciated.
omaster
Junior Member
Posts: 2
Joined: 09 Feb 2014, 05:41


I have solved this issue by disabling ipv6 on server.
zhihao
Junior Member
Posts: 9
Joined: 01 Mar 2013, 01:28


Thank you for your advice. I think maybe "Domain WHOIS Lookup" use ipv6 priority over ipv4. let me try to open port 43 in ipv6 settings or disable ipv6 on server. I will feed back.
zhihao
Junior Member
Posts: 9
Joined: 01 Mar 2013, 01:28


The issue has solved. Thank you for Omaster's advice.

Now I can confirm "Domain WHOIS Lookup" (and "whois" in ssh shell) use ipv6 priority over ipv4.

So just add port 43 in tcp6 out (tcp/ip v6 out) in CSF and everything is OK.
DaveJames77
Junior Member
Posts: 5
Joined: 06 Dec 2016, 08:36


With me it does'nt work. It still blocked.
Alkawps
Junior Member
Posts: 1
Joined: 12 Jan 2018, 11:54


can you please help me to fix this

i have open the 43 for both side
https://drive.google.com/file/d/1ujH8TY ... p=drivesdk
but still got the same issue
https://drive.google.com/file/d/1BzXxD0 ... p=drivesdk
8 posts Page 1 of 1