local-infile=0 versus local_infile=0

2 posts Page 1 of 1
BillyS
Junior Member
Posts: 4
Joined: 31 Aug 2012, 15:02


I have been running CSF for a long time and recently upgraded from MariaDB 10.1 to 10.2. As part of the upgrade, I decided to clean up the my.cnf commands, including moving to underscores instead of dashes.

This morning, I received a warning during CSF's check stating:

Check MySQL LOAD DATA disallows LOCAL
You should disable LOAD DATA LOCAL commands in MySQL by adding the following to the [mysqld] section of /etc/my.cnf and restarting MySQL:
local-infile=0

I checked both the server's setting, which indicated local-infile=0 and my.cnf did have local_infile=0 in the [mysqld] section. It appears CSF only looks for local-infile=0 in my.cnf but should also look for local_infile=0.
BillyS
Junior Member
Posts: 4
Joined: 31 Aug 2012, 15:02


I'm pretty sure this is a bug...

Steps to reproduce in MariaDB 10.2
Insert local-infile=0 in my.cnf and restart MySQL server

Run CSF's Check Server Security
Expected outcome - no warning concerning local-infile setting

Edit my.cnf, replacing local-infile=0 with local_infile=0 and restart MySQL server

Run CSF's Check Server Security
Expected outcome - no warning concerning local-infile setting

Actual outcome, a warning stating:

Check MySQL LOAD DATA disallows LOCAL
You should disable LOAD DATA LOCAL commands in MySQL by adding the following to the [mysqld] section of /etc/my.cnf and restarting MySQL:
local-infile=0
2 posts Page 1 of 1