Add Cyberpanel Control Panel Support

14 posts Page 2 of 2
ForumAdmin
Moderator
Posts: 1449
Joined: 01 Oct 2008, 09:24


If it's possible, we'd like to check your CentOS v7 install as it was developed on that platform, so should work. If so, please log a ticket on our helpdesk:
https://support.configserver.com
whattheserver
Junior Member
Posts: 10
Joined: 03 Oct 2019, 04:40


I apologize I found the issue. It would make sense to check the update function was working on Centos.

csf -u
Oops: Unable to download: Protocol scheme 'https' is not supported (LWP::Protocol::https not installed)

Looks like my Centos and others were missing
yum install -y perl-LWP-Protocol-https

Shows up after installing this and doing a csf -u and refresh cyberpanel main page.

I think this rpm is missing by default with the integrated installer and ill add it in as requirement for Centos when I get a chance.

Thanks again
whattheserver
Junior Member
Posts: 10
Joined: 03 Oct 2019, 04:40


Not super important but noticed the stats section is missing all the graphs due to missing images.
https://imgur.com/a/ScXCEKm

https://ip:8090/configservercsf/iframe/ ... 1571992285

The requested URL /configservercsf/iframe/lfd_systemhour.gif was not found on this server.

When looking noticed that it looks like this folder is missing
/usr/local/CyberCP/configservercsf/static/configservercsf/iframe


Doing a recursive search i was able to find the images in tmp
Code: Select all
[root@wcloud:/]# find / -type f -name "lfd_systemhour.gif"
/tmp/lscpd/lfd_systemhour.gif
/var/tmp/lscpd/lfd_systemhour.gif
[root@wcloud:/]# cd /tmp/lscpd/
[root@wcloud:/tmp/lscpd]# ls
cgid.sock      cgid.sock.633  cyberpanel:_.sock.809  lfd_pie_hour.gif     lfd_systemweek.gif
cgid.sock.015  cgid.sock.839  lfd_cc.gif             lfd_pie_year.gif     lfd_year.gif
cgid.sock.241  csf            lfd_hour.gif           lfd_systemday.gif    lscpd.pid
cgid.sock.418  csf.tgz        lfd_month.gif          lfd_systemhour.gif   swap
cgid.sock.512  csf.tgz.1      lfd_pie_day.gif        lfd_systemmonth.gif
[root@wcloud:/tmp/lscpd]#
I tried creating the folder copying the files and changing perms to match other images that work but did not fix the issue. nor did restarting lscpd service.

I just figured I'd let you know so it can be looked into in a future update.
alfredal
Junior Member
Posts: 1
Joined: 07 Nov 2019, 19:10


22 Oct 2019, 13:19whattheserver wrote:
sweet I see that this was automatically added via a CSF auto upgrade looks really sleek now in the cyberpanel UI. great work.... prestamos con asnef
Recently I could see the automatic update, I think the same as you, it looks great
14 posts Page 2 of 2