CSF Messenger PHP deprecation warnings

This forum is only for reproducible bugs with csf and lfd (i.e. not iptables problems, lack of understanding how to use a feature, etc). Posts must be accompanied with full technical details of the problem and how it can be recreated. Any posts not adhering to this, or not considered bugs, will be moved to the General Discussion (csf) forum.
Post Reply
scrupul0us
Junior Member
Posts: 7
Joined: 25 Nov 2016, 18:45

CSF Messenger PHP deprecation warnings

Post by scrupul0us »

For CSF messenger, the index.php file that handles unblocking, uses curly braces for array indexes/offsets and throws:
Array and string offset access syntax with curly braces is deprecated.
For example:

Code: Select all

$lang{"warning"};
Should be

Code: Select all

$lang["warning"];
-PHP: PHP 7.4.12
-OS: CentOS Linux release 7.9.2009 (Core)
-CSF: csf: v14.08 (cPanel)
ForumAdmin
Moderator
Posts: 1492
Joined: 01 Oct 2008, 09:24

Re: CSF Messenger PHP deprecation warnings

Post by ForumAdmin »

We'll have a fix for this in the next release of csf. Thank you for reporting the issue.
Post Reply