high bug on cxs (help me)

Community forum to discuss cxs.
If you believe that there is a problem with your cxs installation and want support then, as a paid product, you should use the helpdesk after having consulted the documentation.
Post Reply
skinak
Junior Member
Posts: 2
Joined: 17 Jun 2017, 11:43

high bug on cxs (help me)

Post by skinak »

hello

i buy 2 licens cxs and install on my server
but cxs detection this file as virus
easy-digital-downloads/includes/process-download.php

and i must ignore this file on all cpanel users.

It is very difficult

i use this coment
file:home/*/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php

*=all user

but I did not get a positive result

palse help me for this Problem :confused: :confused: :confused: :confused:

thank you
Sarah
Moderator
Posts: 835
Joined: 09 Dec 2006, 22:49

Re: high bug on cxs (help me)

Post by Sarah »

First make sure that you have correctly implemented cxs.ignore:

1. Create a file called /etc/cxs/cxs.ignore. It is a good idea to copy the file /etc/cxs/cxs.ignore.example to /etc/cxs/cxs.ignore so that you have a reference for correct syntax in your ignore file.

2. Add the following setting to the cxs command line for any scan that you want to use the ignore file:

Code: Select all

--ignore /etc/cxs.cxs.ignore

3. Finally, you must use the correct keyword and syntax for the file or directory you want to ignore. There are explanations and examples for the different types of entries you can use, in the file /etc/cxs/cxs.ignore.example.

You cannot use an asterisk (*) as a wildcard in cxs.ignore. If you want cxs to ignore a file in the same location within multiple user accounts, you should use the keyword "hfile:" and include only the part of the path relative to the user's home directory. So, for your example, you would add this line to cxs.ignore:

Code: Select all

hfile:/public_html/wp-content/plugins/easy-digital-downloads/includes/process-download.php

Remember that you must restart cxswatch if you have modified the file /etc/cxs/cxswatch.sh.
Post Reply