MySQL 5.6 update to MySQL 5.7 warnings regarding Strict Mode

Discuss the ConfigServer MailScanner Front-End script
1 post Page 1 of 1
hilario
Junior Member
Posts: 85
Joined: 16 Mar 2008, 23:32


We are in the process of updating our old MySQL from version 5.6 to 5.7 and we saw an warning for WHM/cPanel applications regarding a CRITICAL issue:

MySQL enables "strict mode" by default as of version 5.7. Strict mode controls how MySQL handles invalid or missing values in data-change statements such as INSERT or UPDATE. Applications not built with strict mode enabled may cause undesired behavior; please verify applications using MySQL are compatible before upgrading.

Question 1: Will MailScanner, Mailscanner Front End, MailControl and Mailwatch work OK with MySQL 5.7 and "strict mode"? Any advices to avoid trouble?

Question 2) Our plan is to proceed to upgrade MySQL to MariaDB 10.2.
Are the Mailscanner products compatible with MariaDB?

Question 3) Should we upgrade to Maria DB or stay with MySQL?

Regards,

Hilario Fochi Silveira
1 post Page 1 of 1