cPanel update fails after MSFE Update

Discuss the ConfigServer MailScanner Front-End script
4 posts Page 1 of 1
FourMat
Junior Member
Posts: 9
Joined: 26 Aug 2008, 15:54


I recently updated MSFE to the latest version - v8.06 and now I'm getting a cPanel update failure:

W Exit Code: 3
[2017-05-17 08:22:09 -0400] ***** FATAL: Test install failed: error: Failed dependencies:
[2017-05-17 08:22:09 -0400] cpanel-clamav conflicts with ms-clamav-0.98.5-1.el6.x86_64
E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1495023522.log --force` failed, exited with code 1 (signal = 0)

MailScanner - v5.0.2 installed
ConfigServer MailScanner Script - v3.15 installed and up to date
MailScanner Front-End - v8.06 installed and up to date
cPanel 64.0.20

I'm not sure if MSFE has anything to do with the dependencies, or if this was just a coincidence. I think there had been conflicts between MS and ClamAv installations in the past, but I'm not sure what to do about it. How can I clear this error and allow updates? Thanks.

Matt
dvk01
Junior Member
Posts: 69
Joined: 20 Feb 2010, 18:10


that is probably because MSFE uses ClamAv connector and falls over with the full clam av installed

best to uninstall the full ClamAv & use the cpnel ClamAv connector from within msfe
FourMat
Junior Member
Posts: 9
Joined: 26 Aug 2008, 15:54


CSS installed MSFE for me and configured the system originally, so I'm not sure how ClamAv is interconnected with cPanel and or MSFE. Can someone from CSS address this?
Sarah
Moderator
Posts: 769
Joined: 09 Dec 2006, 22:49


Looks like someone installed clamav from an rpm at some point, which we certainly would not have done. You need to uninstall the ms-clamav rpm and then install clamavconnector via WHM.
4 posts Page 1 of 1