Disabling verification

This forum is now locked due to the majority of recent posts being unrelated to MailScanner. Questions related to MailScanner+exim can go in the MailScanner forum. If you have any questions about exim please direct them to the exim newsgroup (http://www.gossamer-threads.com/lists/exim/users/).
2 posts Page 1 of 1
Turbo
Junior Member
Posts: 1
Joined: 15 Aug 2016, 22:47


I am having a weird issue that I really don't know how to fix. Please be gentle as I know very little about SSH and exim

I am running a Xenforo forum on a VPS and due to GoDaddy's sucky mail method I switched to using an external mail handler called Pepipost. Works great except for any email that is generated by the forum that goes back to an email on the website (such as a user/visitor filling out a Contact Us form, or a user sending a message or generating an email that goes to an account with an email address that = the forum URL like webmaster@***.com), that email bounces like this
Reporting-MTA: dns;****.****.com
X-PowerMTA-VirtualMTA: pepipost-*******-mta
Received-From-MTA: dns;****.*****.com (ip address hidden)
Arrival-Date: Fri, 12 Aug 2016 07:16:27 +0530
Original-Recipient: rfc822;info@****.org
Final-Recipient: rfc822;info@****.org
Action: failed
Status: 5.0.0 (undefined status)
Remote-MTA: dns;****.org (ip address hidden)
Diagnostic-Code: smtp;550 Verification failed for <*****-*****-0-*******.org@delivery.*****.org> No Such User Here Sender verify failed
X-PowerMTA-BounceCategory: block-invalid-sender
and pepipost is telling me this
It seems that you are using EXIM as MTA at your end. Exim has a feature to VERIFY if the SENDER has a valid mailbox before accepting the email from that sender. During verification, if the connection fails, mail is not accepted and the error you mentioned is thrown.
The solution for this is ,the exim config contains entries like this:
deny message = Sender verify failed
!verify = sender
This should be disabled.
I managed to ssh into the server and sudo su - to the root and look at the exim config but I have no clue what I am looking for and don't see what they are talking about.

I run this same exact setup on another forum that is on a shared host and have zero issues...

Any help would be appreciated. Remember, newbie.
Sarah
Moderator
Posts: 785
Joined: 09 Dec 2006, 22:49


Assuming this is a WHM/cPanel server, login to WHM and go to Service Configuration »Exim Configuration Manager. Under Mail, untick Sender Verification Callouts.

If you're not running WHM/cPanel, please go to the exim documentation and/or newsgroup directly for help. See this post for the URLs:
viewtopic.php?f=22&t=944
2 posts Page 1 of 1